Friday, October 6, 2017

exchange 2010 failed to create new GAL

error when trying to create new GAL using:

New-GlobalAddresslist “new GAL” –ConditionalCustomAttribute1 “STAFF” –IncludedRecipients “AllRecipients”

WARNING: One or more global address lists were missing from the Active Directory attribute. This is likely caused by
using legacy Exchange management tools to create global address lists.
Active Directory operation failed on server1.domain.local. This error is not retriable. Additional information: The name ref
erence is invalid.
This may be caused by replication latency between Active Directory domain controllers.
Active directory response: 000020B5: AtrErr: DSID-03152C47, #1:
0: 000020B5: DSID-03152C47, problem 1005 (CONSTRAINT_ATT_TYPE), data 0, Att 907ff (globalAddressList2)
+ CategoryInfo : NotSpecified: (0:Int32) [New-GlobalAddressList], ADConstraintViolationException
+ FullyQualifiedErrorId : 8E376CCD,Microsoft.Exchange.Management.SystemConfigurationTasks.NewGlobalAddressList

 

the most likely problem is corupted entry.

This can be tested using power shell script on AD server:


$ad = [ADSI]"LDAP://rootDSE";
$domain = $ad.rootDomainNamingContext;
$obj = New-Object System.DirectoryServices.DirectoryEntry("LDAP://CN=Microsoft Exchange,CN=Services,CN=Configuration,$domain"); 

$count = 0;
$Gals1= $obj.GlobalAddressList;
foreach($g in $Gals1)
{
   $g= $g.ToString().ToLower(); 
   if($g.Contains("cn=deleted objects"))
   {
      Write-Host $g;
      $count= $count +1;  
   }
}

Write-Host "$Count corrupted GAL entries found in property GlobalAddressList";

$count = 0;
$Gals2= $obj.GlobalAddressList2;
foreach($g in $Gals2)
{  
   $g= $g.ToString().ToLower();
   if($g.Contains("cn=deleted objects"))  
   {
      Write-Host $g;          
      $count= $count +1;  
   }
}
Write-Host "$Count corrupted GAL entries found in property GlobalAddressList2";

you will get output something like this:

cn=default global address list\0adel:cc665233-b490-477a-a972-60fdd6d991ef,cn=deleted objects,cn=configuration,dc=domain,dc=
local
1 corrupted GAL entries found in property GlobalAddressList
0 corrupted GAL entries found in property GlobalAddressList2

If you find corrupted entries (make sure to have full system backup) you will have to remove them using ADSI edit on domain controller.

Using ADSI edit connect to configuration:

configuration\ Services\ Microsoft Exchange (right click / properties)

depending on the listed corruption look for GlobalAddressList or GlobalAddressList2 and click edit.

Remove corrupted entries.

This helped me to fix creating new GAL.

 

reference:

https://social.technet.microsoft.com/Forums/exchange/en-US/52854856-f517-4827-b3d3-3e589a422672/exchange-2010-sp-2-cant-create-second-gal?forum=exchange2010hosters

https://social.msdn.microsoft.com/Forums/en-US/3210af54-d8b4-490f-9f5f-f4fc3209d324/newglobaladdresslist-fails-ad44a06f?forum=os_exchangeprotocols&forum=os_exchangeprotocols

 

https://www.experts-exchange.com/articles/12458/Failed-to-create-New-Global-Address-List-on-Exchange-2010.html

No comments:

Post a Comment

Note: Only a member of this blog may post a comment.

How to Fix ADSelfService Plus SSL Path Errors (GoDaddy P7B Guide)

If you manage ManageEngine ADSelfService Plus on Windows Server 2022 and rely on GoDaddy for your SSL certificates, you have likely run ...